Document information

Document ID:4627
Subject:Running 32-bit applications on 64-bit Ubuntu
Creation date:12/14/15 4:35 PM
Last modified on:3/17/16 8:47 AM


Running Xeams on 64-bit Ubuntu

Note

This page is obsolete. It was created when a 64-bit version of Linux installer was not available. If you are trying to install Xeams on 64-bit Linux, you should download the installer from here.

The installer for Xeams is built for 32-bit version of Linux. This installer comes with a 32-bit JRE (Java Runtime). The 64-bit version of Ubuntu cannot run 32-bit applications without installing the ia32-libs.

You have one of two choices:
  1. Download Xeams for Other Platforms. This file does not contains JRE and therefore, you will have to install JRE separately, which obviously should be a 64-bit version. After installing Xeams and JRE modify run.sh to specify the correct path for java and create start-up scripts so that the server starts automatically when machine is started.
  2. Install the ia32-libs on Ubuntu. Here are some useful links on the Internet that can help you install this library.
    1. http://ubuntuforums.org/showthread.php?t=474790&highlight=getlibs
    2. https://help.ubuntu.com/community/32bit_and_64bit
    3. http://packages.ubuntu.com/jaunty/ia32-libs





Add a comment to this document

Do you have a helpful tip related to this document that you'd like to share with other users? Please add it below. Your name and tip will appear at the end of the document text.
Your name:
Your email:
Hide my email address
Verification code:
Enter the verification code you see above more submitting your tip
Tip:Please limit tips to 1000 characters